Hot Wheels 1:18 – Batmobile (1989)

I bumped into this when I browsing around for 1:50 scale Hot Wheels Batman vehicles, and was absolutely thrilled to discover this gem. This Batmobile from Hot Wheels was originally issued in 2003, but thanks to the Batman hype revolving TDKR, it’s been re-issued for collectors to enjoy once more.

I grew up watching and loving the 2 Burton / Keaton’s BATMAN and BATMAN RETURNS movies, and the design of the Batmobile from these 2 movies have always been the most memorable and iconic to me. The vehicle itself is attached to a display stand via screws (removable), and comes in a perfect size for display, at approximately 12 inches long (incl. base). It’s a nice impressionable size for a collectible, but not so big that it’ll require a lot of effort to clear room for.

The piece is quite heavy due to the use of die-cast in all the appropriate parts, and comes in a slick matte black exterior which oozes badassery and sends the penguins flying.

The wheels turn when you rotate the steering wheel inside the cockpit.

I don’t remember what this phallic device is, but Batman whips it out when he needs to.

The inside of the cockpit is fantastically detailed.

Neat little feature in which the guns pop out from the Batmobile.

I think Hot Wheels did a brilliant job with this, as the piece obviously says “collectible” over toy car. For goodness sake, they charge $50 for that piece of crap “The Bat” over here, which looks to be a monotonous piece of black plastic with no paint targeted towards 6 year-olds.

For some, there’s always the alternative of choosing Hot Toys’ titanic 1/6 scale Batmobile over this. But for us mere mortals, this is the Batmobile to get as part of your movie memorabilia.

Advertisements
    • RoyVF1
    • October 8th, 2012

    Looks awesome! Now that I have just beaten Arkham City, I want a Batmobile figure, and this review made me buy this collectible! Can’t wait to see it in person!

  1. Hi there just wanted to give you a quick heads up and let
    you know a few of the pictures aren’t loading properly. I’m not sure why but I
    think its a linking issue. I’ve tried it in two different browsers and both show the same outcome.

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: